hot-update not working



  • I was using vue-cli and with my previous projects hot-update worked well. In my current project the vue-cli hot-update didn't work. Any change would trigger a complete rebuild which took 40 seconds or more. To make it worse the rebuild would start when I first started typing in the change so when I finished it would finish rebuilding and then start over. All-in-all it was a disaster.

    I posted on the vue-cli forum asking for help and the only response was to switch to vite. The switch was really easy with the webpack-to-vite utility. A complete rebuild in vite went from 40 seconds to 10 which was a pleasant surprise. What is not pleasant is that the hot-update doesn't work with vite either. It is less painful but still a problem. After making any change I use ctrl-c to kill the server and then restart it.

    So what kind of thing could be in my project to kill hot-update? I'm at a loss. When I tried the sample vite app hot-update was instantaneous.

    I know I'm asking a lot but can someone take a peek at my code and look for weirdness that could cause this? Unfortunately you can't run the code because it requires two special servers.

    The code is at https://github.com/mark-hahn/tv-series.


Log in to reply