SBP Block Creation Issues on Feb 8 and 9 (Beijing time)


  • Reward

    Vite Labs is aware of the instability in block creation by SBPs in the last few days. Initial investigation shows that this is caused by anomalies in the transaction data syncing process between nodes. Our engineering team is conducting further analyses.

    In relation to this matter, we would like to mention a few points:

    First, restarting the SBP server may solve the problem (indeed this already has done so for some). If this doesn’t work, please state as such in a reply to this post.

    Second, please pay attention to the notification section of the block explorer and the forum. Any necessary upgrade to solve the block creation problem will be announced in these channels.

    Thank you.


  • SBP Reward

    We've restarted several times in the last few days - doesn't really do anything because network freezes on and off. Requires more than just restarts to fix this problem (like a new Gvite release).

    But it seems to have stopped freezing now, for now. Will continue to monitor our SBP node and report back if there's anything else.

    Other thing to note is that the missed block rate is extremely high right now. Restarting node doesn't do anything to fix that. This must be due to the unstable network. Most SBP nodes are currently in the 35-50% missed rate (when previously it was in the 94-98% range). For example, that's like earning 1000 Vite per day to 350 Vite per day.


  • Reward

    What should be done for full nodes? Most nodes are stuck at block 7436783 and a restart hasn't helped for my node.

    Looking forward to a swift resolution to this issue.


  • Reward

    @fonzie I've updated all my nodes to 1.2.3-alpha4 probably 5-6 days ago. No issues with stucked blocks atm. As I can see most v1.2.2 full nodes have issue with 7436783 block


  • Reward

    @Umcka said in SBP Block Creation Issues on Feb 8 and 9 (Beijing time):

    1.2.3-alpha4

    node gvite version 1.2.3-alpha4
    sync from zero today and stop at 7436783.
    restart gvite, won't work


  • Reward

    @Umcka
    I've some v1.2.2 nodes without problems and some stuck at 7436783.
    I've some 1.2.3-alpha4 nodes without problems and some stuck at 7436783.
    Don't think node version is the cause/solution of the problem.


  • Reward

    @Umcka As others have pointed out, it doesn't seem to be a version issue. Hopefully, a fix is released soon.


  • Reward

    @fonzie Probably. But at most 1.2.2 version affected. I've gathered some online stats (for 515 nodes):
    1.2.3 ~ 11 full nodes affected with bug
    1.2.2 ~ 24 full nodes run without issues, sync is ok
    1.2.2 ~ 38 full nodes have 743***** bug.
    Statistics is not lying in general. You can calculate total percent for every version.
    Approximate numbers, near 25~30 nodes are new.


  • Reward

    @Umcka Hmm. I am still not convinced its something to do with the version. πŸ™‚

    Anyway, let's wait for the official word on this.


  • Reward

    use 1.2.3-alpha4 and have a try with bellow way

    https://github.com/kaidiren/gvite-recover


  • SBP Reward

    @MrFox No source code and only just a binary, sounds a bit dangerous.


  • Reward

    @plasmo you are right, so you can just wait for the next release version


  • Reward

    This post is deleted!

  • Reward

    Hi guys,

    I've made some research. You can check changes on Vite github repo for more details.

    Since Vite team added changes recover option to go-vite main branch I've decided just compile source code by myself. After applying changes with recover command 743***** bug was fixed.

    You can compile by yourself using guide:
    https://vite.wiki/tutorial/node/install.html#compile-source-code

    Make sure you have you have installed gcc

    Run your compiled file with command like:
    ./gvite -config /etc/vite/node_config.json recover -del=7436000
    Then start your main (officially released version).
    I've used 1.2.2 and 1.2.3alpha4 for further sync. Both successfully synced. Hope it will help for all until official release.

    Binary file by MrFox - is compiled gvite. But there no info about any out-Vite additional changes.

    PS Node can stuck few times on 7436783. Simply re-apply recover command again and restart sync.



  • hi guys,
    next release version must wait until the end of the month.
    and there is a temporary gvite to solve this problem.
    https://github.com/viteshan/gvite-tools/releases/download/v0.0.1/gvite_hotfix_20190219

    gvite_hotfix_20190219 is compiled for https://github.com/vitelabs/go-vite/tree/hotfix-20190209-viteshan
    SHA256(gvite_hotfix_20190219)= cded0afb94ba1044b4557fb536d939afbdb80e6c7efdd97ef5746705ae952570


Log in to reply
 

Suggested Topics

  • 1
  • 8
  • 2
  • 1
  • 1
  • 41
  • 1
  • 5