Fullnode not able to sync with NTP server - Google VPS


  • Reward

    Hi Dev team,

    My fullnodes on google VPS have been going down multiple times a day since the upgrade to 1.2.1 and 1.2.2. When I connect to the IPC, I see that the nodes are having a difficulty syncing with the ntp server.

    EROR[01-15|15:30:53] can not get ntp server time: read udp 10.140.0.2:48614->114.118.7.163:123: i/o timeout module=ntp

    Due to that, they are considered 'not alive' even though they are syncing the blocks. Restarting gvite is the only option but is not viable.

    Can you please check and provide a solution for this?


  • Reward

    Similar messages are coming on a different VPS as well. Checked just now:

    -> vite.ledger_getSnapshotChainHeight();
    {"jsonrpc":"2.0","id":3,"method":"ledger_getSnapshotChainHeight","params":[]}
    DBUG[01-16|08:21:19] msg="sending {"jsonrpc":"2.0","id":3,"method":"ledger_getSnapshotChainHeight","params":[]}"
    {"jsonrpc":"2.0","id":3,"result":"3682878"}
    "{"id":0,"jsonrpc":"2.0","result":"3682878"}"
    -> EROR[01-16|08:21:20] can not get ntp server time: read udp 178.128.208.192:41187->203.107.6.88:123: i/o timeout module=ntp
    EROR[01-16|08:21:30] can not get ntp server time: read udp 178.128.208.192:42092->203.107.6.88:123: i/o timeout module=ntp
    EROR[01-16|08:21:40] can not get ntp server time: read udp 178.128.208.192:42906->203.107.6.88:123: i/o timeout module=ntp

    Would this also cause the sync to go slower if the node does not go down fully?


  • Reward

    We have located the uptime problem for google vps. Expect a fix in the next gvite release soon!


  • Reward

    @Allen said in Fullnode not able to sync with NTP server - Google VPS:

    We have located the uptime problem for google vps. Expect a fix in the next gvite release soon!

    So there was something specific for Google? I saw the ntp message on digital ocean droplet as well (second post). That node did not unsync though...


  • Reward

    It has nothing to do with the ntp service but just somehow google's vps got unstable connection to our wss server. I can give you a hotfix file in case you would like to see the result before the formal release.


  • Reward

    @Allen said in Fullnode not able to sync with NTP server - Google VPS:

    It has nothing to do with the ntp service but just somehow google's vps got unstable connection to our wss server. I can give you a hotfix file in case you would like to see the result before the formal release.

    Yes please! I'd like to try it out on one node! 🙂

    Thank you!


  • Reward

    Everything seems to be stable till now. No unsynced node yet. 🙂



  • Tapping on Account Sync gives a list of Google apps when they had been last synced. For immediate assistance, contact Google Live Support.

    1. Change date & time of your device and check if this works. Even if date and time of your device are correct, then also go through following procedure:
    2. Open Settings App of the android device.
    3. In the Settings app, you need to tap on System.
    4. Under the option System, click on Date & Time.
    5. Scroll through and turn off the options Automatic Time Zone and Automatic date & time.
    6. Change date and time so that it shows that both are wrong.
    7. Once you have set wrong date and time, go to home screen.
    8. Again, go to Settings app, and correct wrong date and time.
    9. Turn on the options Automatic date & time.
    10. Again, turn on the option Automatic Time Zone.
      If above troubleshooting method does not help, then, contact Google Live Support to make your account work again.
      Visit: Google Account Recovery

  • Reward

    @Jerry-Matt said in Fullnode not able to sync with NTP server - Google VPS:

    Tapping on Account Sync gives a list of Google apps when they had been last synced. For immediate assistance, contact Google Live Support.

    1. Change date & time of your device and check if this works. Even if date and time of your device are correct, then also go through following procedure:
    2. Open Settings App of the android device.
    3. In the Settings app, you need to tap on System.
    4. Under the option System, click on Date & Time.
    5. Scroll through and turn off the options Automatic Time Zone and Automatic date & time.
    6. Change date and time so that it shows that both are wrong.
    7. Once you have set wrong date and time, go to home screen.
    8. Again, go to Settings app, and correct wrong date and time.
    9. Turn on the options Automatic date & time.
    10. Again, turn on the option Automatic Time Zone.
      If above troubleshooting method does not help, then, contact Google Live Support to make your account work again.
      Visit: Google Account Recovery

    Wait...what?🤔


Log in to reply